Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

Speedometer

Old 15-Feb-2005, 07:03 AM
  #1  
Registered User
Thread Starter
 
Join Date: Jan 2005
Posts: 16
Speedometer

So im driving home from the gym yesterday, and i notice my check engine light come on, weird, first time ever

later on down the road i notice my speedometer is at 0, turned car off, same ****, any idea what it is?

Thanks.
topgear is offline  
Old 15-Feb-2005, 09:24 AM
  #2  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
VSS - Vehicle Speed Sensor located on top of your tranny.
bbarbulo is offline  
Old 15-Feb-2005, 11:08 PM
  #3  
Registered User
Thread Starter
 
Join Date: Jan 2005
Posts: 16
Thanks bud, roughly how much to replace?

a mechanic recommended getting a new cluster from a scrap yard
topgear is offline  
Old 17-Feb-2005, 07:20 AM
  #4  
Registered User
 
Join Date: May 2004
Location: In my Garage
Posts: 703
$155 plus tax @ Honda :S
thats brand new of course
junk yard would be good if you can find one for your car
imported_meSIR is offline  
Old 19-Feb-2005, 10:27 AM
  #5  
Registered User
 
imported_kIeRaN's Avatar
 
Join Date: Mar 2004
Posts: 7,745
if u can find one, they are really easy to replace and you'll be able to find one for alot cheaper then 155 bux.. Put up a wanted ad in the wanted section
imported_kIeRaN is offline  
Old 20-Feb-2005, 12:48 AM
  #6  
Registered User
 
Join Date: Oct 2004
Posts: 116
I had the exact problem as you last week, and then I went to Auto Wreckers on Sewells and picked up a VSS from the place and installed it myself, cost only $75.
bluesicoupe is offline  
Old 23-Feb-2005, 02:14 PM
  #8  
Senior Member
 
imported_Cablerat's Avatar
 
Join Date: Dec 2002
Location: Pickering
Posts: 3,984
Originally posted by The Prophet
my speedo works sometimes and others it doesnt, same problem??
When it stops working the ECU should throw a CEL.
If it doesn't it's not the VSS.

If it's not VSS then it could be the connection back to the cluster is bad, or perhaps even the cluster.

How often does this happen? Any patterns?
imported_Cablerat is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ReDRuM86
Engine
6
31-May-2008 08:32 PM
civic blx
Engine
6
19-Apr-2008 10:01 PM
chubbs
Acura - Honda
4
18-Apr-2008 06:03 PM
gamer123
Interior - Audio - Security
9
01-Jan-2008 02:51 PM
FuRiOuS
Interior - Audio - Security
1
10-Nov-2002 08:35 PM


Thread Tools
Search this Thread
Quick Reply: Speedometer


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.