Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

CEL Code P1508. Please help ASAP :(

Old 01-Aug-2006, 04:44 PM
  #1  
Registered User
Thread Starter
 
imported_2join performance's Avatar
 
Join Date: Nov 2004
Location: Mississauga
Posts: 941
CEL Code P1508. Please help ASAP :(

Hi guys,

I recently did an auto to manual swap, which required me to swap out the intake manifold from an auto to manual one as well. The auto IACV has 3 wires, while the manual one has 2.
So I had the new IACV wired, and the ecu repinned appropriatly.
However, I am throwing a CEL with the code p1508 which is a IAC Valve Circuit Failure.

So what could the problem be? The symptoms I am experiencing is a very low idle, and if I rev and hold the motor and 1500 rpm, the rpm will bounce from 1500 to 1600 constantly.

I am thinking it is either a broken or clogged up IACV, or an improperly wired IACV. Seems more like an electrical problem, which leads me to believe that maybe the wires were soltered wrong, but wouldn't that cause the car to not start at all?

Thanks for all help. I hate electrical problems
imported_2join performance is offline  
Old 01-Aug-2006, 06:36 PM
  #2  
Registered User
 
Bryce's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 1,381
3 things to check..

Check if your coolant level is low.

Also check if your IACV is clogged and check ALL your vacumme tubes... try that?
Bryce is offline  
Old 01-Aug-2006, 06:43 PM
  #3  
Registered User
Thread Starter
 
imported_2join performance's Avatar
 
Join Date: Nov 2004
Location: Mississauga
Posts: 941
Coolant is fine.
No leaks anywhere that I can see.
But how do I check if the IACV is clogged?
imported_2join performance is offline  
Old 01-Aug-2006, 08:40 PM
  #4  
Registered User
 
Bryce's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 1,381
i belive there is a cleaner you can get.... let me search one sec.. ill get you a link.


(add)..

Pull the valve off and clean the screen with a little throttle body cleaner sprayed on a Qtip, then do the reset procedure...

it should say somthing about this in the helms manual
Bryce is offline  
Old 19-Jan-2014, 09:05 AM
  #5  
Junior Member
 
Join Date: Jan 2014
Location: Montreal / Canada
Posts: 3
Hey I know this is a really old thread I am having the exact same problem and I am stumped . what did you do to fix this I've tried everything
cjames241 is offline  
Old 19-Jan-2014, 01:23 PM
  #6  
always building
iTrader: (2)
 
ol Dusty's Avatar
 
Join Date: Mar 2006
Location: In my car
Posts: 1,570
which part is your problem the code p1508 or the idle surge?

If the code is the same as above or at least one related to the IAC and you have the surge then maybe yours is beyond cleaning. The solenoid does fail. New ones even from aftermarket suppliers are expensive, so go to a local junk yard and get a few of them to be sure at least one will work and try switching it. Make sure 500% that you have proper coolant levels and NO AIR in the system. Including the heater core.

If that still hasn't fixed your problem take the same can of brake cleaner used to clean the IAC and spray around the intake manifold slowly. Short bursts around the injectors, sensors like the MAP, IAC, IAT etc. If the engine bogs or stalls then you have a vacuum leak after the MAP sensor so the engine is getting more air then the ECU knows about and the O2 sensor will see this and thing it's running lean. It'll dump fuel and surge high then be to rich and not able to stabilize it self, this can cause a code for the IAC because the valve can't adjust enough to fix the problem and thinks it's out of range.

Lastly if all else has failed and you still haven't solved it. Check to see if there is a FIT valve under the throttle body. If there is then that could be the problem. It'll have a cap on one end held down by 2 phillips head screws. Under that cap is a brass finger and a white ring around it. Turn the ring screwing it back down on the finger and then replace the cap and try the car again.
ol Dusty is offline  
Old 19-Jan-2014, 03:42 PM
  #7  
Junior Member
 
Join Date: Jan 2014
Location: Montreal / Canada
Posts: 3
Hi yes thanks the codes are p1508 and p0420 and the symptoms are exactly the same as the original poster listed above I have done a complete tune up as sell as changed the iacv and didn't find any vaccume leaks and I properly bled the coolant system for air just in case but it didn't seem to have any air in the system the only thing I haven't check was the fit valve but up until today it would start fine idle like normal until the engine would warm up . but today when I went to start the car it went straight to the really low idle just above zero on the tach . just so u know my car is stock 97 1.6vtec
cjames241 is offline  
Old 20-Jan-2014, 03:25 PM
  #8  
always building
iTrader: (2)
 
ol Dusty's Avatar
 
Join Date: Mar 2006
Location: In my car
Posts: 1,570
http://img235.imageshack.us/img235/5872/diagram0ql.jpg

this isn't my pic but it shows the fit valve. the 2 screws on the left side are the ones I was talking about. take that cover off and turn the white ring back down.
ol Dusty is offline  
Old 20-Jan-2014, 07:02 PM
  #9  
Junior Member
 
Join Date: Jan 2014
Location: Montreal / Canada
Posts: 3
Okay perfect I will check it out tomorrow I will let you know how it goes . if not u think it might be time to bring it to my buddys garage
cjames241 is offline  
Old 21-Jan-2014, 10:17 AM
  #10  
always building
iTrader: (2)
 
ol Dusty's Avatar
 
Join Date: Mar 2006
Location: In my car
Posts: 1,570
If it's still giving you a problem then yeah I'd take it in. Not just cause it must be outta your hands but sometimes it just takes a different set of eyes to see the problem.
ol Dusty is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
imported_Turbo-D
Honda Civic Performance - JDM Discussion
2
05-Mar-2007 03:49 PM
imported_yazo
Honda Civic Performance - JDM Discussion
3
20-Jan-2006 12:04 AM
civic_integra
Interior - Audio - Security
11
01-Aug-2005 12:53 PM
mattharper
Maintenance
17
15-Dec-2004 08:12 AM
Alwysfresh
Honda Civic Performance - JDM Discussion
3
20-Oct-2004 01:19 PM


Thread Tools
Search this Thread
Quick Reply: CEL Code P1508. Please help ASAP :(


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.