Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

What could be wrong with my car?

Old 25-Jun-2007, 09:28 AM
  #1  
Registered User
Thread Starter
 
Join Date: Sep 2005
Posts: 26
Unhappy What could be wrong with my car?

Hey..
I have been having some problems with my car lately.. after a long drive like lets say from mississauga to downtown toronto and if i stop for a lil like lets say a gas station or a store for few seconds and than i try to turn the car back on.. it keeps stalling.. and the only way to turn it on is by pumping the accelarator and than turning the car on while pressing it ..

could it have something to do with the fuel filter?? fuel pump? any suggestions?

thanks in advance..
awais is offline  
Old 25-Jun-2007, 02:58 PM
  #2  
Registered User
 
imported_starboy869's Avatar
 
Join Date: Sep 2003
Location: CFB Petawawa
Posts: 2,207
Did the 93 models suffer the main relay problem as the 89-91 Civics?
imported_starboy869 is offline  
Old 25-Jun-2007, 03:00 PM
  #3  
Registered User
 
Join Date: Mar 2007
Posts: 532
the main relays for some reason are **** in all pre 96 models at least... it may seem like pumping the gas helps but I dont think it does.
imported_Kingjames1983 is offline  
Old 25-Jun-2007, 05:39 PM
  #4  
Registered User
 
Join Date: Apr 2007
Posts: 954
well the only way to find out whats going on is by doing a fuel pump test when this problem occurs.
imported_chris_v2 is offline  
Old 26-Jun-2007, 01:16 PM
  #5  
Registered User
Thread Starter
 
Join Date: Sep 2005
Posts: 26
how do u do a fuel pump test? or do i just have to go to a mechanic to get that done?
awais is offline  
Old 26-Jun-2007, 05:33 PM
  #6  
Registered User
 
Join Date: Apr 2007
Posts: 954
mechanic.
imported_chris_v2 is offline  
Old 27-Jun-2007, 08:24 AM
  #7  
Registered User
 
Join Date: Sep 2006
Posts: 150
ive had this issue pop up every so often.. letting the car sit for a few the first time it doesnt start helps..also moving the relay around by hand seems to get rid of the starting issue till the next time it acts up..
Me[kk]A is offline  
Old 27-Jun-2007, 09:38 AM
  #8  
Registered User
Thread Starter
 
Join Date: Sep 2005
Posts: 26
this might sound like a stupid question.. but where is the main relay located?
awais is offline  
Old 27-Jun-2007, 02:44 PM
  #9  
Registered User
 
Join Date: Sep 2006
Posts: 150
assuming it looks like mine..its by your passenger side strut tower.. a set of circuits and such in a plastic covering..
Me[kk]A is offline  
Old 27-Jun-2007, 02:55 PM
  #10  
Registered User
Thread Starter
 
Join Date: Sep 2005
Posts: 26
thanks .. found it

http://www.tegger.com/hondafaq/mainrelay.html this was helpful for anyone else who is having the same prob.. im gonna check it out after work and see if that is the problem or if its something else
awais is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Civic-Roger
2012 Honda Civic Discussion
2
19-Jan-2013 08:02 AM
Civic-Roger
Various Auto News
0
21-Dec-2011 03:29 PM
imported_matt1414
Honda Civic Performance - JDM Discussion
6
07-Dec-2006 09:22 PM
Tego
Interior - Audio - Security
22
10-Sep-2005 12:01 PM
Import Racer
Custom Honda Civic Exterior - Lighting
3
17-Apr-2005 03:41 PM


Thread Tools
Search this Thread
Quick Reply: What could be wrong with my car?


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.