Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

My Civic died :(

Old 18-Mar-2006, 03:34 AM
  #1  
Registered User
Thread Starter
 
imported_d16y8's Avatar
 
Join Date: Jun 2004
Location: Etobicoke
Posts: 621
My Civic died :(

Hey guys, the other day I went to start my car (2000 Civic Si, 92, XXXkm) and it made like a "chh, chh, chh" for like 2 seconds while idling very low, then shut off. It will not start anymore.

I cannot smell any gas when I crank it, so my best assumption is that the fuel pump is gone. The ECU is working because the check engine light still comes on. I have not checked the distributor yet, but tomorrow

I am going to rip apart the car and figure out what the problem is. Does anyone have any suggestions as to what else it may be. Thanks
imported_d16y8 is offline  
Old 18-Mar-2006, 05:28 AM
  #2  
Registered User
 
JEPPA's Avatar
 
Join Date: Aug 2003
Location: Oshawa
Posts: 87
Thought my car was dead this week to. Tis the season to change your distrbutor cap. Just did mine and man it was ugly inside.
JEPPA is offline  
Old 18-Mar-2006, 10:49 AM
  #3  
Senior Member
 
Join Date: Mar 2005
Posts: 6,176
well.. check the CEL
chris_si98 is offline  
Old 18-Mar-2006, 12:06 PM
  #4  
Registered User
 
Join Date: Apr 2002
Posts: 840
could be your battery, cap/rotor, main relay, fuel filter, pump, wires/plugs etc..

mine ended up being my main relay..located under the dash, (passenger side).
EL_CIVIC is offline  
Old 18-Mar-2006, 10:15 PM
  #5  
Registered User
Thread Starter
 
imported_d16y8's Avatar
 
Join Date: Jun 2004
Location: Etobicoke
Posts: 621
Thanks for the input guys. The car does crank, the starter/battery is fine, I'm thinking its prolly the fuel pump or dirty fuel filter. Thanks
imported_d16y8 is offline  
Old 19-Mar-2006, 03:24 AM
  #6  
Registered User
 
imported_Team Rukus's Avatar
 
Join Date: Apr 2002
Location: Moon
Posts: 8,921
do u have gas in your car?
imported_Team Rukus is offline  
Old 19-Mar-2006, 04:13 AM
  #7  
Registered User
Thread Starter
 
imported_d16y8's Avatar
 
Join Date: Jun 2004
Location: Etobicoke
Posts: 621
yes, lots
imported_d16y8 is offline  
Old 19-Mar-2006, 11:26 AM
  #8  
Senior Member
 
Join Date: Mar 2005
Posts: 6,176
are you gettting spark?
chris_si98 is offline  
Old 19-Mar-2006, 12:01 PM
  #9  
Registered User
 
Mr. Death's Avatar
 
Join Date: Jul 2003
Location: Toronto
Posts: 1,003
Try resetting your ecu. Unplug neg terminal on battery for 2 mins.
Mr. Death is offline  
Old 21-Mar-2006, 10:26 AM
  #10  
Registered User
 
Join Date: Jan 2004
Location: North East
Posts: 2,578
Like the others said plus it could be ignitor or ignition coil. See so many of these problems lately already. If it started and was running for a bit and then died then its probably the ignitor. If that is the case it can usually be started again briefly if you let it sit for awhile.
imported_Moe_Mentum is offline  
Old 21-Mar-2006, 07:38 PM
  #11  
Registered User
 
Join Date: Mar 2003
Location: mississauga
Posts: 70
start cheap, change the spark plugs,

checking for spark is absolutely useless, you can get a spark but that doesn't mean it's any good.

if that doesn't work, check the dizzy cap.

if you take a cap apart you should be able to tell right away that something is wrong.
CaptHowdy is offline  
Old 21-Mar-2006, 07:50 PM
  #12  
Senior Member
 
Gallagher's Avatar
 
Join Date: Jan 2003
Location: Your sisters bedroom
Posts: 30,142
should prolly just sell it, not worth it
Gallagher is offline  
Old 22-Mar-2006, 01:35 AM
  #13  
Registered User
Thread Starter
 
imported_d16y8's Avatar
 
Join Date: Jun 2004
Location: Etobicoke
Posts: 621
I changed plugs, distributer cap & rotor, wires, fuel filter and cleaned my intake. Cranked for about 1 minute and she started. Today was a good day.
imported_d16y8 is offline  
Old 22-Mar-2006, 10:30 AM
  #14  
Registered User
 
Join Date: Jan 2004
Location: North East
Posts: 2,578
That is awesome! Good to hear
imported_Moe_Mentum is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
electronblue
Chit-Chat
9
12-Jan-2009 01:06 PM
-cj-
Engine
7
28-Dec-2008 11:17 PM
goat
Chit-Chat
10
25-Jun-2008 12:30 AM
dRd0om
Honda Civic Performance - JDM Discussion
4
07-Jun-2003 07:43 PM


Thread Tools
Search this Thread
Quick Reply: My Civic died :(


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.