Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

Help : no power

Old 15-Jul-2005, 07:05 PM
  #1  
Registered User
Thread Starter
 
Join Date: Feb 2004
Posts: 88
Help : no power

Hi, my car does not get any power at all the. i thaught i might be the battery so i replaced it but still no power i want to know if u guys have any suggestions of wat might be wrong with it.
the car does not start or have any sort of power at all like the interior lights or anything
Any help would be greatly appreciated.
(its a 91 integra btw)
Thanks
imported_terayon is offline  
Old 16-Jul-2005, 09:01 AM
  #2  
Senior Member
 
LEITNER's Avatar
 
Join Date: Jun 2005
Location: At your moms
Posts: 2,633
check all your fuses?
LEITNER is offline  
Old 18-Jul-2005, 03:05 AM
  #3  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
fuses or battery cables?
bbarbulo is offline  
Old 20-Jul-2005, 04:25 PM
  #4  
Registered User
Thread Starter
 
Join Date: Feb 2004
Posts: 88
fuses checked all workin fine and so does the battery cables
could it be the starter??
imported_terayon is offline  
Old 20-Jul-2005, 04:26 PM
  #5  
Registered User
 
imported_JookSingKid's Avatar
 
Join Date: Apr 2002
Location: in the MOSH pit
Posts: 5,550
Main relay?
imported_JookSingKid is offline  
Old 20-Jul-2005, 05:09 PM
  #6  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
starter wouldn't make all your lights not come on, so it's not the starter

did you check both the underhood fuses as well as the ones under the dash? most ppl forget about the main battery fuse under the hood y0
bbarbulo is offline  
Old 22-Jul-2005, 02:46 PM
  #7  
Registered User
Thread Starter
 
Join Date: Feb 2004
Posts: 88
would there be a fuse that if blown all the power would go out.
imported_terayon is offline  
Old 22-Jul-2005, 03:53 PM
  #8  
Senior Member
 
Join Date: May 2003
Posts: 3,745
yes i believe its 100A, dont quote me on that tho
kwikb16a2 is offline  
Old 22-Jul-2005, 04:54 PM
  #9  
Registered User
Thread Starter
 
Join Date: Feb 2004
Posts: 88
thanks man i m guessin its gonna be in the engine compartment
imported_terayon is offline  
Old 22-Jul-2005, 06:22 PM
  #10  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
I think it's 80A not 100.... but why not just pop your hood and look.
bbarbulo is offline  
Old 22-Jul-2005, 08:38 PM
  #11  
Registered User
Thread Starter
 
Join Date: Feb 2004
Posts: 88
jus changed the 70 amp main fuse thanks guys
imported_terayon is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nova_Dust
Honda Civic Performance - JDM Discussion
15
10-Apr-2006 03:08 AM
civicbk
Interior - Audio - Security
3
27-Aug-2005 11:49 AM
civic_integra
Interior - Audio - Security
11
01-Aug-2005 12:53 PM
anoopi
Interior - Audio - Security
2
16-Jul-2005 07:20 PM
imported_andyhoiho
Honda Civic (+ other) Parts/Accessories for Sale or Trade
14
26-Apr-2005 04:41 PM


Thread Tools
Search this Thread
Quick Reply: Help : no power


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.