Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

tps

Old 08-Oct-2010, 10:56 AM
  #1  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
tps

can anyone tell me where i can find an adjustable tps to buy in toronto or scarborough i just have a stock 96 civic dx but my car cuts off on idle or surges and gives hella trouble wen its cold and i dont hv CAA so towing wen it snows is a no no
abstrakt is offline  
Old 08-Oct-2010, 11:08 AM
  #2  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
How do you know for sure it's your tps that is the problem?
MPR is offline  
Old 08-Oct-2010, 11:15 AM
  #3  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
did sum research on it and found sum tips on symptoms and causes i just have to do a volt test which will b 2day so if it is tht for sure and i cant adjust the voltage with the one on the car i would like to at least know where i can buy a new one to be safe instead of goin to the wreckers for 1
abstrakt is offline  
Old 08-Oct-2010, 11:17 AM
  #4  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
made calls to a few places and i keep getting turned to the wreckers or internet in my case they are both a no no
abstrakt is offline  
Old 08-Oct-2010, 11:19 AM
  #5  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
as far as other things with the engine it works fine so far but that engine light and the symptoms to go with it doesnt sit easy cuz its my 1st car and only a week old so jus wana make sure its in working order
abstrakt is offline  
Old 08-Oct-2010, 11:25 AM
  #6  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
What were the CEL codes and what are the symptoms?

Maybe we can help you diagnose the problem...
MPR is offline  
Old 08-Oct-2010, 01:16 PM
  #7  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
im not sure what CEL codes are but the car was sitting for several mnths maybe even a yr so i drove it home n it seemed to be fine but i noticed the engine light front day 1 and i tuned it up and did an LED upgrade on the gauge cluster and dome light but it was while testing the LEDs and the car was at operating temp. it shut off an would not start for 3 days. i had to crank it for nearly half hour before it start again and i bought it as is so i dont know wat probs it has electrically all i know is when i start it idles higher than a car usually would cuz it has to recharge n heat up but its pretty noticeable and whether hot or cold it wud cut off or threaten to cut off so i wud give it a lil gas to keep it going. the only other thing i did to it was a ground wire upgrade from the oem to 4 gauge wire
abstrakt is offline  
Old 08-Oct-2010, 01:17 PM
  #8  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
other than that it runs fine my only other prob is the brake drums i hear like a grinding in them and i think the shoes are too close to the drum but i wana change the drums to rotors if i cud find a swap b4 winter
abstrakt is offline  
Old 08-Oct-2010, 02:07 PM
  #9  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
Originally Posted by abstrakt View Post
im not sure what CEL codes are but the car was sitting for several mnths maybe even a yr so i drove it home n it seemed to be fine but i noticed the engine light front day 1 and i tuned it up and did an LED upgrade on the gauge cluster and dome light but it was while testing the LEDs and the car was at operating temp. it shut off an would not start for 3 days. i had to crank it for nearly half hour before it start again and i bought it as is so i dont know wat probs it has electrically all i know is when i start it idles higher than a car usually would cuz it has to recharge n heat up but its pretty noticeable and whether hot or cold it wud cut off or threaten to cut off so i wud give it a lil gas to keep it going. the only other thing i did to it was a ground wire upgrade from the oem to 4 gauge wire
CEL = Check engine light. Typically, when that comes on, there will be a code. There is a procdure to get the code and if you do a quick google search you can find a write up describing how to get the codes. It’s not hard at all and will save you from having to go to a shop to have it scanned, though some shops may scan your car for free…

Just something to note: On this site, if you hold or hover your curser over any automotive-related abreviation (like CEL, TPS, FPR), a little window will pop up and tell you what it stands for.

After you get the codes from the ecu, post them up and we’ll go from there.

There are a number of reasons it would be running like this. The car having been sitting for so long could be a contribution to the issue (s).

Some possibilities:
-bad gas
-dirty fuel filter
-bad injector(s)
-o2 sensor(s)
-clogged cat
-bad dizzy, ignition components
-dirty IACV (idle air control valve)

And the list goes on…

Originally Posted by abstrakt View Post
other than that it runs fine my only other prob is the brake drums i hear like a grinding in them and i think the shoes are too close to the drum but i wana change the drums to rotors if i cud find a swap b4 winter

Just something to keep in mind about rear brakes; Although they don't look pretty, drum brakes are great to have because you'll rarely ever replace any parts on them. Just adjust them every now and then and they will last nearly forever. As far as braking fuction, drums work perfectly good for daily driving. Especially at the ligh-weight ***-end of a little civic. Don't get me wrong though, it's a nice, inexpensive upgrade.

Last edited by MPR; 08-Oct-2010 at 02:11 PM.
MPR is offline  
Old 08-Oct-2010, 02:09 PM
  #10  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
thanx on the info ima go check it out n c what happens
abstrakt is offline  
Old 08-Oct-2010, 03:46 PM
  #11  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
Forgot to mention, your car is OBD2, so you'll need to search for the procedure to reterieve the codes from a civic with OBD2 ecu.
MPR is offline  
Old 09-Oct-2010, 12:39 AM
  #12  
Senior Member
 
PurpleStuff's Avatar
 
Join Date: Jan 2009
Location: Pick. er. ing.
Posts: 1,870
How to check CEL code (from honda-tech.com)

Admin, this link should honestly be sticky'd. or copied and pasted into a new thread, it's been brought up toooooooo many times. and it would help out everyone!
PurpleStuff is offline  
Old 12-Oct-2010, 10:20 AM
  #13  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
Originally Posted by PurpleStuff View Post
How to check CEL code (from honda-tech.com)

Admin, this link should honestly be sticky'd. or copied and pasted into a new thread, it's been brought up toooooooo many times. and it would help out everyone!
This: http://www.torontocivics.com/f121/ch...e-light-11610/

MPR is offline  
Old 15-Oct-2010, 04:24 PM
  #14  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
it blinked once so i checked out ur link n its my oxygen sensor will tht cause my car 2 shut off randomly
abstrakt is offline  
Old 16-Oct-2010, 06:51 PM
  #15  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
The O2 shouldn't cause the engine to stall randomly, but it could cause the other problems you've mentioned...
MPR is offline  
Old 17-Oct-2010, 12:17 AM
  #16  
Senior Member
 
jdm ek4's Avatar
 
Join Date: Sep 2007
Posts: 730
Did you do a full tune up? Cap n Rotor, plugs, wires, new oil, and filter. If you said the car may have been sitting for a year, you might want to change that fuel filter aswell. Does your battery terminals have corrosion build-up, clean that up as well.
jdm ek4 is offline  
Old 17-Oct-2010, 04:44 PM
  #17  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
i did
oil
oil filter
ground wires
new battery
i have to buy a fuel filter and air filter and the brakes were done due to the lines blowing out at the back and the master cylinder was destroyed but this was with the previous owner. so all i have 2 do is the fuel and air filter and plugs and wires but the oxygen sensor as far as doing the engine check is concerned for a 96 car im not sure if they ever changed it but i will change that and see if the light comes off. at the price of 150 at canadian tire and parts source . . . . it better be that
abstrakt is offline  
Old 17-Oct-2010, 04:49 PM
  #18  
Guest
Thread Starter
 
Join Date: Sep 2010
Posts: 24
but as for cutting off still the only other thing that was on the list was the IAT sensor at number 10 and being a noob im not sure how long a flash of the engine light should be and its worst it only flashing once . .

1. o2 sensor
10. IAT sensor
abstrakt is offline  
Old 30-Oct-2010, 10:23 AM
  #19  
F8i
Senior Member
iTrader: (10)
 
F8i's Avatar
 
Join Date: Mar 2009
Location: Kincardine
Posts: 769
How is everything going?
Update!

Please remember to use the EDIT button instead of reposting onthe forum.
F8i is offline  
Old 30-Oct-2010, 11:41 AM
  #20  
Senior Member
 
PurpleStuff's Avatar
 
Join Date: Jan 2009
Location: Pick. er. ing.
Posts: 1,870
Fyi, there is only a "edit" button for those who pay, or are gear heads, pr team, etc. If you're a regular member like me, we don't have an edit button.
PurpleStuff is offline  

Thread Tools
Search this Thread
Quick Reply: tps


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.