Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

Speedometer problem

Old 06-Oct-2010, 10:15 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2010
Posts: 1
Speedometer problem

The speedometer on my '93 Si is working intermittently. In fact, in warm weather it hardly ever works, and in cold weather it works 3/4 of the time! Anyone else had this? If it's the sending unit, anybody have a used one for a decent price (budget's real tight right now!)

Thanks!
SteveB is offline  
Old 06-Oct-2010, 10:42 AM
  #2  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
If it has a speed sensor and not a cable, then that is probably the problem. but before you go buy one to replace it, make sure it's plugged in and the wires are not damaged.
MPR is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fragment
Interior - Audio - Security
2
12-May-2011 12:52 PM
smokeybanana
Interior - Audio - Security
3
20-Mar-2011 05:55 PM
jdmferio
Interior - Audio - Security
1
19-Sep-2010 11:36 AM
ReDRuM86
Engine
6
31-May-2008 08:32 PM
gamer123
Interior - Audio - Security
9
01-Jan-2008 02:51 PM


Thread Tools
Search this Thread
Quick Reply: Speedometer problem


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.