Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

Hot air all the TIME!!

Old 20-Mar-2010, 04:14 PM
  #1  
Member
Thread Starter
 
JonnyPie's Avatar
 
Join Date: Feb 2010
Location: Burks Falls
Posts: 55
Hot air all the TIME!!

hello so I have a 96 EK HB and the venting system is always blowing hot air not matter what! even if I put it to cold air and turn on the A/C still blows out hot air being as summer is around the corner I would like to fix this issue I am having any one have any ideas?

give you so history I just got the car in march the prev. owner had done an engine swap (hope he changed the ECU not sure if he did though) so maybe there is a wire or poss. a fuse? hope its some thing small like that. any ways let me know your ideas

Cheers Jonny
JonnyPie is offline  
Old 20-Mar-2010, 04:36 PM
  #2  
Senior Member
 
Join Date: Feb 2010
Location: Waterloo, Ontario
Posts: 1,074
could need a heater core flush and the entire system really, it does wonders, hopfully its something small
JDMej1 is offline  
Old 20-Mar-2010, 05:48 PM
  #3  
Member
 
Join Date: Mar 2010
Location: Trenton, Ontario
Posts: 54
are the vents controlled by Vacuum or is it mechanical behind the dash? could start buy looking there?. im new to Honda so its just a stab in the dark from what i've seen on my other car.
90_CivicHB is offline  
Old 20-Mar-2010, 06:05 PM
  #4  
Member
Thread Starter
 
JonnyPie's Avatar
 
Join Date: Feb 2010
Location: Burks Falls
Posts: 55
not sure what it is controlled by have to take a look into that.

mmm yeah good idea to get the heater core flushed
JonnyPie is offline  
Old 21-Mar-2010, 11:42 AM
  #5  
Member
 
Join Date: Sep 2007
Posts: 95
Could it possibly be the valve controlling hot coolant entering the heater core... maybe stuck open?
dirtywat is offline  
Old 21-Mar-2010, 11:44 AM
  #6  
Member
 
Join Date: Sep 2007
Posts: 95
At the risk of sounding dumb... Did the previous owner even keep the A/C after the swap? haha

Is the compressor working?
Do you have a refrigerant leak?
Is there refrigerant in the system?
dirtywat is offline  
Old 21-Mar-2010, 12:20 PM
  #7  
Junior Member
 
Join Date: Jul 2009
Posts: 25
check the valve that controls the coolant flow to the heater core if its stuck open and temperature cable from the dash to the valve if it still moves, the cable might be broken.
princephan is offline  
Old 21-Mar-2010, 12:34 PM
  #8  
Member
Thread Starter
 
JonnyPie's Avatar
 
Join Date: Feb 2010
Location: Burks Falls
Posts: 55
Dirtywat-come to think of it i dont think he did hahahaha going to be working on the car today check all the areas to see! thanks for the ideas....will keep you posted!
JonnyPie is offline  
Old 21-Mar-2010, 12:41 PM
  #9  
Member
 
Join Date: Sep 2007
Posts: 73
Originally Posted by JonnyPie View Post
hello so I have a 96 EK HB and the venting ........Cheers Jonny
96 Ek hatch has mechanical cable for heater temp control hot to cold.

Either the cable is disconnected or the valve/cable hook assembly in the engine bay at the firewall is stuck/broken or the same thing has happened at the control slider end of the cable in the cabin.
nsxvtec is offline  
Old 21-Mar-2010, 03:04 PM
  #10  
Member
Thread Starter
 
JonnyPie's Avatar
 
Join Date: Feb 2010
Location: Burks Falls
Posts: 55
yeah just spent about an hour messing around with it and it was the cable on the cabin side running from the temp control unit.....the whole metal slider was disconnected and was stuck on hot air! so hope that i have fixed it only one way to tell for sure thats to drive it or let it run....will let you know if its fully fixed when i go out for a drive.

Thanks to everyone that had posted ideas as to what could have been the problem!

Cheers Jonny
JonnyPie is offline  
Old 21-Mar-2010, 03:04 PM
  #11  
Member
Thread Starter
 
JonnyPie's Avatar
 
Join Date: Feb 2010
Location: Burks Falls
Posts: 55
sorry should have took pics was not thinking.

and yes there is no A/C unit any more wires are still there hahaha
JonnyPie is offline  
Old 22-Mar-2010, 03:34 PM
  #12  
Member
Thread Starter
 
JonnyPie's Avatar
 
Join Date: Feb 2010
Location: Burks Falls
Posts: 55
Issue is fixed
JonnyPie is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Adair
Chit-Chat
41
13-Sep-2006 11:38 AM
minimatchit
Honda Civic (+ other) Parts/Accessories for Sale or Trade
0
23-Mar-2006 06:18 PM
HI-ROLLA
Honda Civic (+ other) Parts/Accessories for Sale or Trade
11
12-Dec-2005 11:37 AM
Raziel
CFz Discussion
11
22-Jul-2004 02:18 PM


Thread Tools
Search this Thread
Quick Reply: Hot air all the TIME!!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.