Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

Help on emissions.

Old 10-Feb-2005, 09:29 PM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 767
Help on emissions.

I have a 92 civic hatch with a 1.6L sohc v-tec D16z6. Today i did emissions and the readings were failing. The NOX were so high up and it wouldn't pass. I changed my Cat and i thought that was the problem. Problem was still there afterwards. I find that if i disconnect the temp sensor the NOX went down like no tomorrow and passing and HC and Co went high and failing now. I plug the sensor back in and it changes the opposite. The happens to the Oxygen sensor too when i unplug the sensor. I have a new rad and new thermostat. Try to adjust the timing, but iy didn't really hep. My problem is what else can i change.

A mechanic told me it could be computer related meaning ECU. I'm not sure what kind of ECU the people had in before. Where does it tell u what ECU chip u have on the passenger side underneath the foot. I know where the ECU is located but does it tell u what ECU it is? So my problem is how many of u think it is the ECU? If not what else could i change. I really need help because i have to do my e-test before this month and i already spend too much $$$ on parts to try and make it pass. I need someone that knows HONDA inside out and can figure out my problem.


Give me some ideas if u can. If u are so sure or a possibilty know the problem pls reply the thread thanx.

Honda don't have EGR rite? What ECU should a stock civic hatch have and what about the Si hatch have? What's the code on it. Is it P28 or something else????
imported_winner007 is offline  
Old 10-Feb-2005, 10:09 PM
  #2  
Registered User
 
Join Date: Mar 2004
Posts: 1,431
NOX runnign lean, when you unplugged the temp sensor??? it obviously made it run rich so the HC and CO went up. Um any good e test shop should tell you exactly what you need. I dont' know what to tell you but get right heat range plugs make sure your o2 is reading correctly.
dingus88 is offline  
Old 11-Feb-2005, 12:06 AM
  #3  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
stock dx ecu for a 92 is a P06, and a VTEC D16Z6 is a P28. located in the pass side kickpanel.

NOx readings indicate high combustion temps... I suggest you go to a shop and let them figure it out. You're obviously getting nowhere with what you're doing now. high EGTs could be caused by a lotta diff't things.
bbarbulo is offline  
Old 11-Feb-2005, 02:12 AM
  #4  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 767
I do work in a shop that do emissions. We all still can't figure it out what's wrong with it. They say it is most likely the computer now and not the sensors because whatever sensor i unplug the nox goes down and the rest of the hc and co fails after. So it shouldn't be the o2 sensor. Thanx for all your help ppl.
imported_winner007 is offline  
Old 11-Feb-2005, 02:13 AM
  #5  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 767
Where is the obd1 scanner plug located for a eg civic hatch? Does anyone know?
imported_winner007 is offline  
Old 11-Feb-2005, 10:25 AM
  #6  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
why not test the O2 sensor?? warm car up... check voltage of the O2. though NOx failing does NOT indicate O2 anyways. How much are you failing by on NOx? If it's a lil bit, maybe 94 octane fuel will bring it down enough to pass cuz 94 octane burns cooler (harder to ignite). Also heat range of your plugs??

scanner is under the dash, next to the fuse box. (at least mine is)
bbarbulo is offline  
Old 11-Feb-2005, 07:11 PM
  #7  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 767
Thanx bbarbulo. My nox is supposed to be 576 max and my readings were like 2000. When i disconnect any sensors like the temp sensor or the oxygen sensor my nox drops to like 100 or less, but the HC and the CO goes up and fails. I'm going to test the 02 sensor on Mon because i was looking for the scanner plug so i can hook up the scanner and see if the oxygen sensor fluctuates on the reading. Thanx for all your help.
imported_winner007 is offline  
Old 13-Feb-2005, 08:43 AM
  #8  
Registered User
 
imported_zc_hatch's Avatar
 
Join Date: Aug 2003
Location: Kingston
Posts: 1,090
my everything was high when i went to do emissions and i brought it down ALOT just by retarding the timing, it cools the combustion temps down some.... might wanna give that a try

-Matt
imported_zc_hatch is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
civic_integra
Interior - Audio - Security
11
01-Aug-2005 12:53 PM
imported_D dot T
Honda Civic Performance - JDM Discussion
19
31-May-2005 10:45 AM
imported_winner007
Maintenance
9
25-Feb-2005 03:41 PM
imported_Fug
Maintenance
8
11-Feb-2005 12:01 AM
90hatchsi
Honda Civic Performance - JDM Discussion
20
25-Feb-2004 12:57 AM


Thread Tools
Search this Thread
Quick Reply: Help on emissions.


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.