Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

Car wont start!

Old 18-Feb-2005, 11:50 AM
  #1  
Registered User
Thread Starter
 
Join Date: May 2003
Posts: 42
Angry Car wont start!

Hey, my civic wont start today, we had a really cold night - and I''m hoping its just from the cold - the accesories come on.... so I think the battery is fine. when I turn the ignition I hear a clear "CLICK" noise, and nothing else. just had the alternator replaced.... any suggestions or ideas what the click sound is????

tks
imported_Jayzen is offline  
Old 18-Feb-2005, 11:58 AM
  #2  
Registered User
 
Join Date: Apr 2004
Location: Burlington, Ontario
Posts: 92
If all it does is click when u try to start it, it can be the battery, it doesn't take much to light up the dash compared to starting the vehicle. Start withthe battery and go from there, boost it and see.
StreetWyze is offline  
Old 18-Feb-2005, 11:59 AM
  #3  
Registered User
 
Mr. Death's Avatar
 
Join Date: Jul 2003
Location: Toronto
Posts: 1,003
I had the same prob. My battery didn't have enough juice. Get someone to give ya a boost just to rule out the battery.
Mr. Death is offline  
Old 18-Feb-2005, 12:01 PM
  #4  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
most likely battery. need min 400 CCA to get a civic started
bbarbulo is offline  
Old 18-Feb-2005, 12:40 PM
  #5  
Registered User
Thread Starter
 
Join Date: May 2003
Posts: 42
thanks

yes it was the battery - I'm guessing extreme cold made it lose its charge?
imported_Jayzen is offline  
Old 18-Feb-2005, 12:44 PM
  #6  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
or just an old battery?? either way you got it fixed... BTW, I wouldn't call -10 or -15 EXTREME cold hahaha
bbarbulo is offline  
Old 18-Feb-2005, 12:53 PM
  #7  
Registered User
Thread Starter
 
Join Date: May 2003
Posts: 42
I think I got this battery 6 months ago from walmart - so I think it should be ok - and when I replaced my alternator 1 month ago they said it was goood.....

I hate spending money - makes me think of getting a new car in the summer

oh and its bone chilling cold today - must be the windchill
imported_Jayzen is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mr Man
Engine
3
16-Sep-2008 01:11 PM
iceburg_shorty
Honda Civic Performance - JDM Discussion
20
09-Oct-2004 05:49 PM
white92d15b7
Honda Civic Performance - JDM Discussion
16
03-Jan-2004 10:48 AM
neilff
Honda Civic Performance - JDM Discussion
21
01-Aug-2003 09:19 AM
imported_1sicsol
Honda Civic Performance - JDM Discussion
10
27-Feb-2003 07:06 AM


Thread Tools
Search this Thread
Quick Reply: Car wont start!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.