Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

car runs horrible after engine detail

Old 04-Jun-2011, 10:27 PM
  #1  
Senior Member
Thread Starter
 
dreamr's Avatar
 
Join Date: Oct 2007
Location: newmarket
Posts: 326
car runs horrible after engine detail

Ok so I decided to clean my discusting engine bay as its probably never been done...
I used a pressure washer for the shock towers, firewall and any other body colour parts under my my hood. When I was all done and after the car sat for about a hour I went to leave where I was and the car ran fine.
About ten munits Into my drive it started acting up. Kinda like a missfire at all rpm and has f all for power. Sounds like a subaru now...any ideas?????
dreamr is offline  
Old 05-Jun-2011, 12:18 AM
  #2  
MPR
Senior Member
 
MPR's Avatar
 
Join Date: Sep 2007
Location: Where my car is.
Posts: 5,460
Sounds like you got your ignition system components all wet. It happens.

Could be a sign your wires, dizzy cap & rotor are on their way out. If they're old, might be time for a tune up.
MPR is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Andrew
CFz Discussion
12
09-Nov-2008 12:48 AM
Joker
Custom Honda Civic Exterior - Lighting
2
31-Oct-2007 12:39 PM
dhr
Interior - Audio - Security
1
18-Jul-2006 01:36 PM
RealHatch
Honda Civic (+ other) Parts/Accessories for Sale or Trade
5
30-Mar-2005 01:30 PM
AzimuthX
CFz Discussion
1
17-Oct-2002 11:19 PM


Thread Tools
Search this Thread
Quick Reply: car runs horrible after engine detail


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.