Maintenance oil changes, what fluids, tires etc...ask your general manitenance questions in here or look up the answer before you post.

2 Weird Issues

Old 12-Feb-2011, 11:29 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2010
Posts: 11
2 Weird Issues

First, i just changed my thermostat a few days ago, my blower motor is working (wirings a bit weird) but my heat just stopped working.. all that comes out is cold air even when on hot.. my temp only goes to just right before half..

Second, when i changed my thermostat and drove the car out of my garage and let it run a few seconds , my fuel gage started to work again (was stuck at full before ) then dropped to half after . But after about 15 minutes it went back. Im not sure whats wrong .

Btw its a 95 si
killahkam is offline  
Old 13-Feb-2011, 11:17 AM
  #2  
Senior Member
 
Join Date: Feb 2010
Location: Waterloo, Ontario
Posts: 1,074
first, did you bleed the cooling system after changing the stat? if not thats why your heat doesnt work; you have air pockets in your cooling system.

second, i'd take a guess that your floater on your sending unit isnt functioning properly, or your sending unit itself is malfunctioning and not sending the correct signal for the level of fuel actually in your tank to your fuel gauge. just a guess though, would need proper diagnosing to find the actual proeblem
JDMej1 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Midori
Engine
8
12-Jun-2008 11:34 PM
phlipino
Engine
4
23-Dec-2007 01:28 PM
honda1b6a
Engine
6
18-Dec-2007 01:07 PM
LDX
Honda Civic Performance - JDM Discussion
0
07-Sep-2007 02:01 AM


Thread Tools
Search this Thread
Quick Reply: 2 Weird Issues


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.