Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

turbo'd gsr problem

Old 24-Jul-2006, 04:07 PM
  #1  
Registered User
Thread Starter
 
Join Date: Mar 2005
Posts: 55
turbo'd gsr problem

a friend of mine had a gsr boosted with a t3/t4 ... he told me he was driving to niagara falls (from toronto) and when he was almost there it sounded like he had an exhaust leak .... then he said the car wouldn't rev beyond 1500 rpm and there's tons of black smoke coming out his exhaust ... could an electrical connector have come off or something?? sounds like a tuning problem, but the exhaust leak sound confuses me too .. maybe a combination of factors?? anybody encounter something like this before??
imported_93si_coupe is offline  
Old 24-Jul-2006, 04:17 PM
  #2  
Senior Member
 
Join Date: Dec 2005
Location: hamilton/burlington
Posts: 479
if there isn't an exhaust leak to be found, sometimes a loose silicone coupler on the charge piping can cause an exhaust leak type sound but i'd say that isn't his problem since he is getting the smoke and the odd rpm problem. if he wasn't building boost i'd say it is probably a coupler problem though.
imported_weiRtech is offline  
Old 24-Jul-2006, 05:22 PM
  #3  
Senior Member
 
Join Date: Mar 2005
Posts: 6,176
do a compression test.

An electrical connector falling off (which is rare) wouldn't cause a bunch of black smoke to come out
chris_si98 is offline  
Old 24-Jul-2006, 06:09 PM
  #4  
Registered User
Thread Starter
 
Join Date: Mar 2005
Posts: 55
the reason i thought it was an electrical connector is because maybe the fuel management computer connector came loose and as a result the car runs like *** ... don't even know if that's possible but the thought crossed my mind .... anyways i'll check the couplings
imported_93si_coupe is offline  
Old 24-Jul-2006, 06:41 PM
  #5  
-- site donator --
iTrader: (1)
 
Join Date: Mar 2004
Location: the hammer
Posts: 7,038
if 1 of the ecu plugs came loose the car wouldn't run.
I would start with a compression test like c-pos said.
But it sounds like an ignition related problem. Check the distributor, take the cap and rotor off so you can slide the black plastic peice off and see inside the dizzy. There are some good procedures of checking the ICM, coil, etc in a haynes/chilton manual. I suggest getting one to help with your troubleshooting.
I'd also check the MAP sensor, a bad map sensor can cause a car to run all sorts of messed up.
Whats he doing in terms of tuning?
zeeman is offline  
Old 24-Jul-2006, 07:40 PM
  #6  
Registered User
 
Join Date: Apr 2006
Posts: 261
probobly coupler came off then caused mad running rich map not reading...no air and tons of fuel....
dingus888 is offline  
Old 24-Jul-2006, 08:46 PM
  #7  
Senior Member
 
Join Date: Mar 2005
Posts: 6,176
Originally posted by zeeman
I would start with a compression test like c-pos said.
hey zeepos. watch your mouth or else no mcChicken's for you tomorrow
chris_si98 is offline  
Old 24-Jul-2006, 08:49 PM
  #8  
-- site donator --
iTrader: (1)
 
Join Date: Mar 2004
Location: the hammer
Posts: 7,038
mmmmmm.....mcChicken
zeeman is offline  
Old 24-Jul-2006, 08:50 PM
  #9  
Senior Member
 
Join Date: Mar 2005
Posts: 6,176
mmmmmmmmm

wet mcChicken.
chris_si98 is offline  
Old 25-Jul-2006, 12:57 AM
  #10  
Registered User
 
Mr. Death's Avatar
 
Join Date: Jul 2003
Location: Toronto
Posts: 1,003
Sounds to me like your ecu is running in limp mode. The first p28 I bought for my turbo d was in limp mode and it desplayed the same problems your having. Try another ecu and compare the 2.
Mr. Death is offline  
Old 01-Aug-2006, 02:48 AM
  #11  
Registered User
Thread Starter
 
Join Date: Mar 2005
Posts: 55
sorry it took so long to get back guys, just got my car back from the body shop and have been working like mad to get it ready and enjoy the little good weather we still have left ... they problem with my buddy's car was a vacuum line that came off the compressor side of the turbo .. it didn't have a clamp on it and i guess it just came off over the course of his drive .. thanks again for all the input .. much appreciated
imported_93si_coupe is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bengali548
CFz Discussion
19
23-Jul-2009 08:40 PM
imported_littledevilcrx
Honda Civic (+ other) Parts/Accessories for Sale or Trade
8
02-Sep-2007 07:40 PM
SiR b16a2
Honda Civic (+ other) Parts/Accessories for Sale or Trade
5
03-Jul-2006 02:21 PM
imported_allmotorhonda
Honda Civic (+ other) Parts/Accessories for Sale or Trade
11
09-Aug-2005 04:40 PM
92SiHB
Honda Civic (+ other) Parts/Accessories for Sale or Trade
5
07-Sep-2004 08:50 AM


Thread Tools
Search this Thread
Quick Reply: turbo'd gsr problem


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.