Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

something's wrong with my car, help pls?

Old 19-Jul-2005, 07:57 AM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 5
something's wrong with my car, help pls?

hi!

My car doesn't seem to accelerate, car was started successfully, no problem about the starting. But when I am in 1st gear, it doesn't seem to move and have some weird noise from the exhaust. then, when i tried to give more gas, it was ok. but then between first start --> ok, i think i restarted my car for like 10 times. not sure if it's clear enough......have anyone experienced on that? My car is a 2000 Civic SiR.

many thanks!
happy_pooh is offline  
Old 19-Jul-2005, 09:04 AM
  #2  
Senior Member
 
cibs's Avatar
 
Join Date: Aug 2002
Location: Mississauga
Posts: 13,184
you have to be more specific
cibs is offline  
Old 19-Jul-2005, 09:10 AM
  #3  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 5
i'd love to, but i am dummy to the car.

it's stock yr 2000 SiR engine (i don't even know if it's B16 A B C). there's cat back exhaust but oxygen sensor seems dead, cat converter seems not working as well. (failed emission test)

when i tried to press the gas pedal, the RPM meter looks funny (goes up and down) and it produces weird noise, the car won't go at all, then it stalls becoz of that. (to make it worse, the car was in uphill position). then, when i try to give a lot of gas, the car suddenly seems ok.

is that specific enough? i wish i can translate it into car language. thanks.
happy_pooh is offline  
Old 19-Jul-2005, 09:16 AM
  #4  
Registered User
 
imported_gatherer's Avatar
 
Join Date: Jan 2003
Location: on a race track
Posts: 17,846
take it to a mechanic
imported_gatherer is offline  
Old 19-Jul-2005, 09:18 AM
  #5  
Registered User
 
imported_trackhack's Avatar
 
Join Date: Oct 2004
Location: Durham
Posts: 993
Originally posted by gatherer
take it to a mechanic
Couldn't have said it better myself.
imported_trackhack is offline  
Old 19-Jul-2005, 09:19 AM
  #6  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 5
that's true and right.

thanks.
happy_pooh is offline  
Old 19-Jul-2005, 02:50 PM
  #7  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
you are experiencing a misfire. time for a tune up.
bbarbulo is offline  
Old 19-Jul-2005, 02:57 PM
  #8  
Registered User
 
Younes Si's Avatar
 
Join Date: Aug 2004
Posts: 6,753
how many km on the car?
Younes Si is offline  
Old 20-Jul-2005, 08:44 AM
  #9  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 5
what's misfire means?


it has high KMs~~~
happy_pooh is offline  
Old 20-Jul-2005, 11:58 AM
  #10  
Registered User
 
imported_Torrey's Avatar
 
Join Date: Oct 2002
Location: Stoney Creek, Ontario
Posts: 3,657
I'd really suggest you take it to someone who knows whats goin on... or PM scott93si.
imported_Torrey is offline  
Old 20-Jul-2005, 12:17 PM
  #11  
Registered User
 
ELGUY's Avatar
 
Join Date: Jan 2005
Posts: 415
yeah same thing. Sometimes missfires are caused by shorting out or cracked plugs/plug wires. Sounds like you need a good tune up, possible 02 sensor. Ive seen bad 02 sensors that dont even throw a check engine light. If its that bad, a tune up will make your car feel much better once again.
ELGUY is offline  
Old 20-Jul-2005, 12:54 PM
  #12  
Registered User
 
imported_kIeRaN's Avatar
 
Join Date: Mar 2004
Posts: 7,745
it means take it to a mechanic
imported_kIeRaN is offline  
Old 20-Jul-2005, 01:54 PM
  #13  
Registered User
Thread Starter
 
Join Date: Apr 2004
Posts: 5
lol, my O2 sensor is dead already.

i need to go to work~~~ so can't really take to mechanic until the weekend. after changing the spark plugs, it seems better now.

thanks everyone for your advice. I will take it to mechanic asap
happy_pooh is offline  
Old 20-Jul-2005, 05:14 PM
  #14  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
a misfire is when the car is supposed to light the air/fuel mixture in the cylinder, but it doesn't. it most often happens due to a neglected dist cap and rotor, bad plugs, or bad plug wires. sometimes it can happen from too rich of a mixture, too cold of a plug, or a bad distributor.... all of which is kinda unlikely in your case. just get a tuneup done like you're supposed to.

generally ppl who follow the Honda maintenance schedule NEVER have problems with their cars.
bbarbulo is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Gallagher
Chit-Chat
14
06-Jul-2008 11:22 AM
imported_chaego
Honda Civic Performance - JDM Discussion
0
20-Nov-2006 10:55 PM
civic_integra
Interior - Audio - Security
11
01-Aug-2005 12:53 PM
imported_tyip02
Custom Honda Civic Exterior - Lighting
8
01-Jul-2005 02:45 AM
Gallagher
Honda Civic Performance - JDM Discussion
12
31-Mar-2003 09:00 AM


Thread Tools
Search this Thread
Quick Reply: something's wrong with my car, help pls?


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.