Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

Mount problem!

Old 04-Sep-2003, 09:06 PM
  #1  
Registered User
Thread Starter
 
Join Date: Apr 2002
Location: Richmond Hill
Posts: 517
Mount problem!

to make a long story short...
driverside-front engine mount (a/c compressor attaches to this)
needs to be replaced but the problem is that when it was installed one of the bolts that threads into the frame of the car was forced to hard and ended up breaking the weld of the nut it connects to in the frame

i need to get this out...thinking of cutting into the frame from the top in order to get at the nut with socket/wrenches whatever works and then back off the bolt...then re-weld the nut back onto the frame from the top...

any suggestions!?!?

anybody actually understand the nonsense i'm giving you?
imported_spl_civic is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
army031
Acura - Honda
1
16-Aug-2008 07:49 PM
imported_CARLiTO_
Honda Civic Performance - JDM Discussion
22
23-Jun-2007 12:17 AM
imported_weiRtech
Honda Civic Performance - JDM Discussion
14
12-Feb-2006 11:46 PM
imported_narcisis
Honda Civic (+ other) Parts/Accessories for Sale or Trade
0
01-Apr-2005 03:16 PM


Thread Tools
Search this Thread
Quick Reply: Mount problem!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.