Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

H22 in EK help!!....markpa this is for you!

Old 01-Aug-2006, 08:55 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jan 2006
Location: Mississauga
Posts: 265
H22 in EK help!!..

i have a question about h22's in ek's for anyone who has one out there. im currently using the ETD mount kit and the front mount (torsion bar i think) does not fit to the tow hooks cause the rad and fan are in the way. im going to ETD to see if they can help with the situation but it just doesnt look like its gonna fit. im currently riding without it, i havent banged gears cuz i dont have that 4th mount. what mount kits are you using. i know markpa should have the same set up, do you have that front crossmember mount on? ETD is a four mount set up, but AVID is only a 3. what should i do, ill be happy if the can fabricate something that fits. id just like to know how the ek's are holding up with the h22's?

thanks guys.

oh and one last thing, what intake are you using. mine doest fit from my b16.
imported_torscot is offline  
Old 01-Aug-2006, 11:57 PM
  #2  
Senior Member
 
Join Date: Jul 2006
Location: Durham Region
Posts: 161
yeah i have the hcp kit i think its practically the same as the etd one, If u want to keep the front mount, I had to get a slim fan ($80), i tried trimming the stock one but it wouldnt fit. The intake that Im using is the Intake i had on my d16y8, Tight fit, around the fuel filter but It fit, Just loosen the fuel filter bracket, bend it back a bit, the intake should work.

U could off pmd me, I would of responded faster...
markpa2 is offline  
Old 02-Aug-2006, 11:14 AM
  #3  
Registered User
Thread Starter
 
Join Date: Jan 2006
Location: Mississauga
Posts: 265
i grabed a slim fan too but it still didnt fit. also my check oil light is on, the oil is clean and full, they said its a short in the oil temp wire thats behind the oil filter. if i just jiggle it or push it up it should go away, does this sound right?
imported_torscot is offline  
Old 02-Aug-2006, 01:46 PM
  #4  
Senior Member
 
Join Date: Jul 2006
Location: Durham Region
Posts: 161
Originally posted by torscot
i grabed a slim fan too but it still didnt fit. also my check oil light is on, the oil is clean and full, they said its a short in the oil temp wire thats behind the oil filter. if i just jiggle it or push it up it should go away, does this sound right?
who did your install? Check your oil pressure , oil light doesnt go on when your low on pil or have dirty oil, Either a loose connection, or low oil pressure.
markpa2 is offline  
Old 02-Aug-2006, 02:46 PM
  #5  
Registered User
Thread Starter
 
Join Date: Jan 2006
Location: Mississauga
Posts: 265
yea it was a loose conection, just got it fixed, it was a short in the wire, no problem, fixed and good to go!
imported_torscot is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
imported_FukenRicen
Honda Civic (+ other) Parts/Accessories for Sale or Trade
0
23-Nov-2006 12:20 AM
civic_integra
Interior - Audio - Security
11
01-Aug-2005 12:53 PM


Thread Tools
Search this Thread
Quick Reply: H22 in EK help!!....markpa this is for you!


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.