Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

Gs-r

Old 06-Jun-2006, 07:44 AM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2006
Posts: 16
Gs-r

i ahve a 96 integra gsr my problem is that the engine clicks alot and is pretty noisy and also when i am drive and my rpm's are high it makes like a high pitched noise anyone know what would cause that and does any one know what would cause the engine to clikc like that?
JiZeR123 is offline  
Old 06-Jun-2006, 11:28 AM
  #2  
Junior Member
Thread Starter
 
Join Date: May 2006
Posts: 16
JiZeR123 is offline  
Old 06-Jun-2006, 12:02 PM
  #3  
Registered User
 
Join Date: Jan 2004
Location: North East
Posts: 2,578
Well the clicking is problem due to the the valves. You probably just need a valve adjustment (typical tune up thing). Take it to the dealer or a shop that knows their Hondas. The high pitched noise at higher RPMS eh?


HAHA I really hope this isn't the problem. But did you hit your VTEC!? If so that's not good
imported_Moe_Mentum is offline  
Old 06-Jun-2006, 12:21 PM
  #4  
Senior Member
 
imported_Cablerat's Avatar
 
Join Date: Dec 2002
Location: Pickering
Posts: 3,984
Can you tell where the high pitched sound is comign from?

My transmission used to emit a high pitch sound in my 90 integra at high rpms. Never did figure out the problem, just sold it as is.
imported_Cablerat is offline  
Old 06-Jun-2006, 01:14 PM
  #5  
Registered User
 
imported_kungfugrip's Avatar
 
Join Date: Jan 2006
Location: Toronto
Posts: 2,087
JDM VTEC
imported_kungfugrip is offline  
Old 06-Jun-2006, 01:37 PM
  #6  
Registered User
 
Join Date: Jul 2005
Location: North of Toronto
Posts: 371
What kind of fuel are you running? if your running 87 octane, you could be pinging!
imported_Christof is offline  
Old 06-Jun-2006, 04:21 PM
  #7  
Registered User
 
Join Date: Feb 2003
Location: Mississauga
Posts: 395
Originally posted by callmesir
JDM VTEC
haha sounds like yours? lol JDM my **** lol
B16A_SiR is offline  
Old 06-Jun-2006, 05:37 PM
  #8  
Registered User
 
imported_kungfugrip's Avatar
 
Join Date: Jan 2006
Location: Toronto
Posts: 2,087
Originally posted by B16A_SiR


haha sounds like yours? lol JDM my **** lol
wtf no
imported_kungfugrip is offline  
Old 06-Jun-2006, 05:38 PM
  #9  
Registered User
 
Bryce's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 1,381
Originally posted by callmesir
JDM VTEC
lol
Bryce is offline  
Old 07-Jun-2006, 12:42 AM
  #10  
Registered User
 
1sykcoupe's Avatar
 
Join Date: Nov 2004
Location: tdot
Posts: 1,341
lol lol virgin`
1sykcoupe is offline  
Old 07-Jun-2006, 08:28 AM
  #11  
Junior Member
Thread Starter
 
Join Date: May 2006
Posts: 16
well i jus got my valves adjusted and it still makes the noise and also what do u mean by did i hit my vtec?
JiZeR123 is offline  
Old 07-Jun-2006, 09:10 AM
  #12  
Registered User
 
Join Date: Oct 2004
Location: Milton
Posts: 439
I believe I've read that worn out LMAs (lost motion assy) can be noisey as well. Just a thought.
I'm not sure how to check for this however. You'll prolly have to remove the cams.
sohcnotec is offline  
Old 07-Jun-2006, 06:39 PM
  #13  
Junior Member
Thread Starter
 
Join Date: May 2006
Posts: 16
anyone else got any ideas?
JiZeR123 is offline  
Old 08-Jun-2006, 05:44 PM
  #14  
Junior Member
Thread Starter
 
Join Date: May 2006
Posts: 16
???
JiZeR123 is offline  
Old 10-Jun-2006, 02:41 PM
  #15  
Registered User
 
Join Date: Jan 2004
Location: Whitby, Ontario
Posts: 524
Give me a pm, id be glad to check it out for you , no charge...
1sloweg is offline  

Thread Tools
Search this Thread

Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.