Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

evap. code

Old 13-Oct-2007, 12:41 PM
  #1  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
Thumbs down evap. code

hey guys,

My check engine light has been coming on for the past month now, i take it to the shop at least twice a week, its like i live there. But, we ahve changed everything there is that it shows in the evap code to change and the light is still coming off. Has this happened to anyone else? Is there something else that is setting off the evap code that you know of?

Plz HELP!
I want this light gone already.

BTW its a 2000 civic coupe, std.

thanks guys.
si_ponz is offline  
Old 13-Oct-2007, 12:51 PM
  #2  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
ok it's real simple. if you had changed the RIGHT thing, the light wouldn't be on anymore. blame your mechanic not the car. take it to a shop that knows what they're doing (ie. the dealership). there are quite a few things that can set the evap code, including the gas cap I believe, but instead of thowing money at your car, just take it to a dealership.
bbarbulo is offline  
Old 13-Oct-2007, 01:57 PM
  #3  
Senior Member
 
chris_v2's Avatar
 
Join Date: Sep 2007
Location: Pfaff
Posts: 1,556
wtf is wrong with you? Why would you pay for the service if the light is still on? Why would u continue to go back?

EVAP codes can be set by numerous things, faulty sensors, leaks in your lines, tank, hoses, etc. Usually the code will tell you whats wrong (ie faulty sensor or system leak) a smoke test will quickly find a leak..

Anyways, find a new shop
chris_v2 is offline  
Old 13-Oct-2007, 04:05 PM
  #4  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
obviously im not throwing money at the car. There are many things that set off the code which I KNOW and so does my mechanic. I have changed everything the evap. code says and my gas cap and did a smoke test (no leaks in my car)

SO i was wondering if you guys knew of anything else that could set off an evap code or has anythign like this ever happened to you.

thanks.
si_ponz is offline  
Old 13-Oct-2007, 04:42 PM
  #5  
Senior Member
 
chris_v2's Avatar
 
Join Date: Sep 2007
Location: Pfaff
Posts: 1,556
your mechanics a dummy. And gives professionals like myself a bad name. Cant even diagnosis a friggen evap code..
chris_v2 is offline  
Old 13-Oct-2007, 04:48 PM
  #6  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
so why dont i bring it to you, and you can tell me whats wrong with it? Because obviously he doesn't he has changed everything and the light still comes on for the same code, i dont get this. its so annoying.
si_ponz is offline  
Old 13-Oct-2007, 04:49 PM
  #7  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
ok simmer down chris

si ponz, if it was something simple we could think of off the top of our heads, you would have prolly replaced it already. I have't seen this issue before. however, honda's manuals have very detailed simple troubleshooting trees that are to be done in the event of any code. if you follow the troubleshooting tree, you will get to a diagnosis. that's why I said, time to take it to the dealer, they're usually pretty good at following the troubleshooting and they have all the required eq't to do it properly.
bbarbulo is offline  
Old 13-Oct-2007, 04:51 PM
  #8  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
or I'm sure chris can do it too, he's a smart cat. hook up with him and see if he can help you out.
bbarbulo is offline  
Old 13-Oct-2007, 05:03 PM
  #9  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
well i took it to honda, honda wanted 750 for 4 parts to replace, since i just bought the car i wasn't gonna put out all that money, the guy i bought the car from said i have 36 days, so i called him up then he told me to go to his cousins shop in woodbridge, thats where i have been going, and we have changed all the parts that honda said even, even tho honda says to change the parts just so they dont have to worry about opening it up to take a look and see which part is the problem, they think, just change them all and have the problem gone. So, basically that is the reason why i didn't get it done at honda, if i had the car for a year i would have let Honda do it, but i just dished out the cash for the car and then this goes wrong, so i wasn't gonna dish out more money then i have to since i had the warranty.
si_ponz is offline  
Old 13-Oct-2007, 06:06 PM
  #10  
-- site donator --
iTrader: (2)
 
bbarbulo's Avatar
 
Join Date: Aug 2002
Location: not Toronto
Posts: 27,687
well then start to suspect a bad ECU or bad wiring. if the components have been replaced, that's where you look next. swap in a known good ecu and see if you get the same code. if yes, then start tracing down wiring.
bbarbulo is offline  
Old 14-Oct-2007, 12:32 AM
  #11  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
how much do ECU's usually run for?
si_ponz is offline  
Old 10-Nov-2007, 07:14 AM
  #12  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
Well the light is still coming on just so you guys know, and for the exact same code. We are basically at the stage of taking out the light, anyone think this is a good or bad idea? Honda can't even figure it out since Honda is giving everything to my mechanic, I think my mechanic is sending me to his buddy at Honda first to let him see what is going on. The guy at Honda already knows that my mechanic did all the work smoke tested my car a few times to make sure, he did EVERYTHING.

I hope they figure it out, this light is such a pain.
si_ponz is offline  
Old 22-Nov-2007, 09:52 AM
  #13  
Senior Member
Thread Starter
 
si_ponz's Avatar
 
Join Date: Sep 2007
Posts: 711
Hey, well i took it to honda, they said it was my ECM, 1400 for a new one, and 525 for a used, went the used route, the next day the light still came on, i donno what the **** to do, any opinions guys, the car runs mint, or any one know how to take the check engine light out?

let me know guys, im gettin fed up with this bull.
si_ponz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
B-lue16A_EK
Honda Civic (+ other) Parts/Accessories for Sale or Trade
0
14-Mar-2006 05:11 PM
ginoboy1978
Honda Civic (+ other) Parts/Accessories for Sale or Trade
1
19-May-2005 11:54 AM
Alwysfresh
Honda Civic Performance - JDM Discussion
3
20-Oct-2004 01:19 PM
imported_spl_civic
Honda Civic Performance - JDM Discussion
6
27-Jul-2003 01:37 PM
imported_D dot T
Honda Civic Performance - JDM Discussion
4
04-Jun-2003 12:09 AM


Thread Tools
Search this Thread
Quick Reply: evap. code


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.