Honda Civic Performance - JDM Discussion Engine tech, forced induction, springs, shocks, brakes, tires, etc.

Check Engine Light Problem

Old 11-Mar-2006, 07:56 PM
  #1  
Registered User
Thread Starter
 
imported_Team Rukus's Avatar
 
Join Date: Apr 2002
Location: Moon
Posts: 8,921
Check Engine Light Problem

So i am getting two codes.

10 and 65

10= IAT
65= Secondary O2 sensor.


here is my problem. the engine is reving up and down between 1000 and 2000 rpm once the engine warms up at idle. Or the engine just stays at a 3000rpm rev at idle.

At first i thought it could be the IACV but it doesnt have an IACV engine code comming up just IAT.

anyone have a clue?


its a d16y7 in a 96 civic.


btw i am running only water right now in the coolant system no antifreeze because I was performing tests. could that have anything to do with it too?
imported_Team Rukus is offline  
Old 11-Mar-2006, 08:22 PM
  #2  
Registered User
Thread Starter
 
imported_Team Rukus's Avatar
 
Join Date: Apr 2002
Location: Moon
Posts: 8,921
running stock airbox aswell.
imported_Team Rukus is offline  
Old 11-Mar-2006, 08:33 PM
  #3  
-- site donator --
iTrader: (1)
 
Join Date: Mar 2004
Location: the hammer
Posts: 7,038
It could be the IACV, i've had faulty IACV's without a CEL. I would try the fast idle thermo valve trick.
If you wanna know what that is i'll explain it on msn to you.
zeeman is offline  
Old 11-Mar-2006, 08:55 PM
  #4  
Senior Member
 
Join Date: Mar 2005
Posts: 6,176
the iat could be contributing to your idle problem, could it not? It might be bouncing to compensate for it. Atleast thats what I would think.
chris_si98 is offline  
Old 11-Mar-2006, 09:00 PM
  #5  
Registered User
Thread Starter
 
imported_Team Rukus's Avatar
 
Join Date: Apr 2002
Location: Moon
Posts: 8,921
i still think its iacv cuz i have had a couple of cars have that problem previously. but they all had the iacv code light but this time it doesnt and its saying iat. now the sensor plugs into the side of the air box do you guys really think it could actually contribute that much?

i will try changing it and hopefully it will help.

btw does anybody here know where the plug for the secondary o2 sensor is?
imported_Team Rukus is offline  
Old 13-Mar-2006, 04:29 PM
  #6  
Registered User
 
Dhany92's Avatar
 
Join Date: Aug 2005
Location: Cambridge
Posts: 184
problem

i had taht problem with my civic aswell, at first it would just stay at a high ilde all the tiem and hten it started going up nad down from 1500 to 3000 back and forth,
on ur throddle body underneath it there is a censor it looks like its part of the throddle body, 2 phillips screws holding it on, take it apart nad inside will be some sping and a bolt, the bolt had come loose tighten that bolt and put everything back together and ur car should run mint!
Dhany92 is offline  
Old 13-Mar-2006, 10:41 PM
  #7  
Registered User
Thread Starter
 
imported_Team Rukus's Avatar
 
Join Date: Apr 2002
Location: Moon
Posts: 8,921
thanks for the help but i believe that only holds true for 92-95 because the iacv's on the y7 and y8's were different compared to the gen 5 models.
imported_Team Rukus is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
96_civic_jdm
Engine
0
29-Jun-2014 01:58 PM
toofast4u
Honda Civic (+ other) Parts/Accessories for Sale or Trade
0
10-Feb-2010 09:52 PM
2drcivic
Engine
14
16-Mar-2008 07:03 AM
nemo1
Intakes - Headers - Exhausts
5
04-Feb-2008 04:52 PM
ds2chan
Custom Honda Civic Exterior - Lighting
8
30-Apr-2006 10:41 PM


Thread Tools
Search this Thread
Quick Reply: Check Engine Light Problem


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.